Bo mes cloud pa adresbuki i kalendario

Skirbi · 28 feb 2020

Bo mes cloud pa adresbuki i kalendario

Kompartí kontakto, agenda i tarea ku CardDAV/CalDAV

Si bo ta usa diferente aparato i kompiuter pa hasi bo trabou, bo lo ke sinkronisá kontakto, agenda i tarea. Bo por usa kualkier di e servisionan di 'cloud grandi' pa esaki, manera Apple iCloud, Microsoft Office 365 i Google Gmail. Pero si bo prefer di no kompartí bo adresbuki i kalendario ku kompanianan grandi merikano, bo por hasié bo mes.

Pakiko hasié bo mes?

Aunke ta mashá kómodo pa usa un servisio grandi di cloud pa sinkronisá adresbuki i kalendario, tin bon rason pakiko bo lo ke hasié bo mes:

  • kontròl: si bo mes ta kore e cloud di Adresbuki/Kalendario, bo ta kontrolá kon e ta funshoná, kuantu e ta kosta, ken tin akseso na dje, etc.
  • privasidat: aunke e kompanianan grandi ta bisa ku nan 'ta balorá bo privasidat', nan no ta duna ningun garantia ku ningun hende lo wak bo data. Mi ke ku mi adresbuki (ku sita, detaya di proyekto, etc) i kontakto (nòmber, número, aniversario) ta privá.
  • libertat: si bo usa protokòl habrí pa kore bo cloud di Adresbuki/Kalendario, bo por usa e riba tur bo aparato.

Kon hasié: CardDAV/CalDAV

Pa maksimo libertat i fleksibilidat den e skohimentu di e aparatonan ku bo ta usa, bo mester skohe un denominador komun ora bo ta buska solushon ku ta pèrmití kompartí adresbuki i kalendario. Pa fortuna tin un solushon asina den e estándarnan habrí CardDAV i CalDAV.

Tantu CardDAV komo CalDAV ta ekstenshon di e estándar WebDAV. Web Distributed Authoring and Versioning (WebDAV) mes ta un ekstenshon di e protokòl estándar HTTP. Ta un protokòl ku ta pèrmití varios kliente (aparato/kompiuter/app) kompartí un rekurso (file/adresbuki/kalendario/etc).

CardDAV

E protokòl CardDAV ta un protokòl pa kompartí adresbuki. Apple a proponé dje promé komo estándar na 2007, RFC 6352. E protokòl ta usa WebDAV pa kompartí data di kontakto den e formato di file "vCard". Mihor bo pensa riba un vCard komo un karchi di negoshi virtual. CardDAV ta laga bo kompartí bo koleksion di karchi di negoshi virtual entre bo aparatonan.

CalDAV

E protokòl CalDAV ta un protokòl pa kompartí kalendario. Meskos ku CardDAV Apple a proponé dje promé komo estándar, RFC 6638. E ta usa WebDAV pa kompartí data di sita den e formato iCalendar. E "Internet Calendaring and Scheduling Core Object Specification" ta un estándar habrí tambe, RFC 5545, ku ta wòrdu sostené hopi. CalDAV ta laga varios aparato i app tin akseso na bo kalendario, loke ta pèrmití planifikashon kooperativo i kompartimentu di informashon.

CardDAV/CalDAV ta rekerí un server

Pa traha ku CardDAV/CalDAV bo tin mester di un server ku ta aktua komo lugá sentral di almasenahe di bo data di adresbuki/kalendario. Diferente di konekshon 'peer-to-peer' (kaminda bo lo konektá bo telefòn ku bo kompiuter), e protokòl CardDAV/CalDAV ta desèñá pa traha via internet. E server sentral ta laga aparato i app konektá i sinkronisá data independiente di otro.

Server CardDAV/CalDAV ta konektá ku aparato i app
Server CardDAV/CalDAV ta konektá ku aparato i app

Komo e protokòl ta basá riba teknologia di web (efisiente), e rekisitonan pa e server ta mínimo. Bo no tin mester di prosesador poderoso òf hopi memoria di almasenahe. Algun hende ta kore nan CardDAV/CalDAV for di un kompiuter barata Raspberry Pi. Òf bo por usa un VPS chikí, un NAS òf un kompiuter bieu.

Software di server CardDAV/CalDAV

E software di server CardDAV/CalDAV ta konsistí di dos parti: e sistema operativo di server i e server real di CardDAV/CalDAV. Pasobra e ta definí komo estándar habrí, bo ta liber pa skohe e sistema operativo bo mes. GNU/Linux ta un skoho komun komo sistema operativo di server. Diferente distribushon hopi bia ta bin ku un repositorio di software kla pa usa, manera un 'app store', ku ta laga bo instalá app di server ku fasilidat.

Sistema operativo

Na armonia ku mi otro servisio di cloud, mi hopi bia ta skohe Debian GNU/Linux. E ta un sistema operativo ku ta liber di presion komersial, ku ta duna prioridat na libertat riba interes di negoshi. Pesei e ta un base ekselente i stabil pa kualkier proyekto di server.

Implementashon di server CardDAV/CalDAV

Riba e sistema operativo di server bo mester instalá software di server ku ta implementá e estándarnan CardDAV/CalDAV. Bo mes mester wak e diferente server: server di CardDAV i server di CalDAV.

Despues di analisá e diferente opshon di server CardDAV/CalDAV, mi a destilá e tres opshon aki:

  • Apple Calendar-Server: Komo Apple a skirbi e espesifikashon original di CardDAV/CalDAV, nan a desaroyá un server kompletu i a hasié open source. Aunke esaki ta parse bon, a stòp e desaroyo di Calendar Server (na lugá di Apple iCloud). Tin un "Notice of Archival" riba e pagina di GitHub di Calendar Server. E ta sigi funshoná, pero su futuro no ta seguro.
  • ownCloud: Un solushon popular 'pa tur kos' ku ta implementá CardDAV/CalDAV ta ownCloud. E tin un nòmber apropiá, pasobra e ta laga bo 'ta dueño di bo henter cloud'. Su desventaha prinsipal ta ku e ta purba hasi tur kos, inkluí email i kompartí file, kisas muchu, segun bo nesesidatnan.
  • Server Radicale: Desaroyá komo un server CardDAV/CalDAV chikí ma poderoso, liber i open source, Radicale ta hasi djis esei: kompartí kalendario i adresbuki. Su desaroyo ta bibu, impulsá pa e kompania franses Kozea ku ta hasi hopi trabou pa kuido di salú públiko. Segun mi opinion, e server CardDAV/CalDAV aki ta tantu kompakto komo saludabel, i esei ta hasié un skoho ekselente.

Instalá Radicale riba Debian/GNU Linux

Instalá Radicale riba Debian ta tan fásil ku 'apt-get install radicale'. Bo mester wak e instrukshonnan detayá di instalashon riba e Debian Wiki: instalá radicale riba debian.

E instalashon básiko di Radicale ta traha bon ku nòmber di usuario i password simpel (for di un file riba e server). Pero komo software liber i open source, tin opshon pa integrá Radicale ku diferente forma di outentikashon i siguridat:

  • outentikashon di nòmber di usuario i password di Radicale kontra un server IMAP: Si bo kaba ta manehá un server di mail, bo lo ke benefisiá di e manehu di nòmber di usuario i password ku kaba tin. Bo por 'monta riba' e manehu di usuario di CardDAV/CalDAV riba bo infraestruktura ku kaba tin via plugin di outentikashon. Tin plugin (bon) ku ta traha pa usa Radicale ku IMAP, disponibel ku kódigo di orígen.
  • kore Radicale tras di un proxy NGINX: Bo por fortifiká Radicale, for di un punto di bista di siguridat sibernétiko, dor di kore e tras di un reverse proxy server NGINX ku a pasa prueba di bataya. Bo ta haña tur e ventahanan ku NGINX ta ofresé, inkluí sertifikado TLS/SSL outomátiko via Let's Encrypt. Instrukshon pa kuminsá ku esaki ta disponibel den e dokumentashon di Radicale pa Apache i pa NGINX.

Konektá ku bo server CardDAV/CalDAV: kliente

Un bes ku bo server CardDAV/CalDAV ta kore, bo mester konfigurá bo aparatonan pa konektá ku dje. Bo por hasi esaki na diferente manera, segun e tipo di aparato ku bo usa.

  • Apple macOS: Konfigurá bo Mac pa konektá ku un server CardDAV/CalDAV ta fásil. Djis agregá komo kuenta na macOS, wak instrukshon pa CardDAV i CalDAV
  • Apple iOS/iPadOS: Meskos ku e Mac, konfigurá bo iPhone òf iPad pa konektá ku un server CardDAV/CalDAV ta fásil. Djis agregá komo kuenta, bou di "Settings". Instrukshon pa CardDAV i CalDAV.
  • Android: Pa mihor integrashon bo mester usa un app di sinkronisashon ku ta konektá e databasenan di kalendario i kontakto di Android ku e server CardDAV/CalDAV. Mi tin bon eksperensia ku CardDAV-Sync i CalDAV-Sync
  • Windows: Aunke Microsoft tin sostén integrá pa CardDAV/CalDAV den Windows 10, e no ta laga bo konfigurá dje pa usa ningun otro servisio ku iCloud, a menos ku bo hasi trukinan funky. Si bo usa Outlook bo por usa un plugin open source Caldavsynchronizer.org pa konektá ku bo server.
  • GNU/Linux: Si bo ta usa software liber riba PC bo tin hopi opshon pa konfigurá dje pa konektá ku e server CardDAV/CalDAV. Si bo ta kore GNOME komo desktop environment bo mester wak e instrukshonnan aki.

Konklushon

Komodidat ta algu bunita, te ora e pika bo for di patras. E "servisionan grandi di cloud" ku e gigantenan merikano di teknologia ta operá ta duna manera fásil (i gratis) pa sinkronisá bo agenda personal i adresbuki. Si bo ke tuma kontròl riba bo mes data personal (òf di trabou), bo mester konsiderá monta bo mes server di adresbuki i kalendario.

No ta tan difísil di berdat pa hasié bo mes, i si bo tin mester di yuda, bo semper por pidi un hende pa yuda bo. Ora bo tin e kore, bo lo tin mas kontròl riba bo data, mihor privasidat i libertat pa skohe bo aparato i app. No ta malu, no?

← Mas artíkulo